Internet Explorer จะเริ่มบล็อค ActiveX คอนโทรลรุ่นเก่า ตั้งแต่ 12 ส.ค. นี้

Internet Explorer

ไมโครซอฟท์ประกาศว่า ตั้งแต่ 12 ส.ค. เป็นต้นไป Internet Explorer จะเริ่มบล็อค ActiveX คอนโทรลรุ่นเก่า (out-of-date) ไม่ให้ทำงานตั้งแต่แรกแล้ว เนื่องด้วยเหตุผลด้านความปลอดภัย

หลักการทำงาน คือ IE8-IE11 บน Windows 7 SP1 และ IE บนโหมดเดสก์ท็อป บน Windows 8 หรือสูงกว่า จะตรวจสอบ ActiveX คอนโทรลที่จะถูกโหลดขึ้นมากับไฟล์รายชื่อที่บริษัทสร้างขึ้นและถูกดาวน์โหลดไปเก็บไว้ในเครื่องไคลเอนท์โดยอัตโนมัติ

สำหรับใครที่ใช้ Java รุ่นเก่าดังต่อไปนี้ เบราว์เซอร์จะทำการบล็อคโดยอัตโนมัติ (รายชื่อทั้งหมดดูได้จากที่นี่)

  • J2SE 1.4 ต่ำกว่า Update 43
  • J2SE 5.0 ต่ำกว่า Update 71
  • Java SE 6 ต่ำกว่า Update 81
  • Java SE 7 ต่ำกว่า Update 65
  • Java SE 8 ต่ำกว่า Update 11

ทั้งนี้ ผู้ใช้ยังสามารถดูเนื้อหาบนหน้าเว็บส่วนที่ไม่เกี่ยวข้องกับ ActiveX คอนโทรลนั้นได้ตามปกติ และสามารถรัน ActiveX คอนโทรลที่ถูกบล็อคได้โดยการกดปุ่ม Run this time ที่แถบการแจ้งเตือนและกดปุ่ม Allow ในหน้าต่าง Internet Explorer Security (ดูภาพที่ท้ายข่าว) นอกจากนั้น หากเว็บไซต์ที่ใช้ ActiveX คอนโทรลรุ่นเก่าถูกเพิ่มเข้ารายชื่อ Local Intranet Zone หรือ Trusted Sites Zone จะไม่มีบล็อค ActiveX คอนโทรลดังข้างต้น

สำหรับผู้ดูแลระบบ สามารถศึกษาการกำหนดค่าเบราว์เซอร์บน Group Policy ได้จากที่มาของข่าวครับ

ที่มา: IEBlog  By: nuntawat  blognone.com

ภาพแสดงการแจ้งเตือนว่า ActiveX คอนโทรลถูกบล็อคบน IE8

ภาพแสดงการแจ้งเตือนว่า ActiveX คอนโทรลถูกบล็อคบน IE9-IE11

ภาพแสดงหน้าต่างถามผู้ใช้ว่าจะอนุญาตให้ ActiveX คอนโทรลทำงานหรือไม่